How to turn on the other plugins?


Maybe recreate plugins.json and then run:

docker stop

docker start


Ok, I’m back in the office. Will try recreating the plugins.json again and restart the container.


Hey, started sorta from scratch. I stopped and rm the containers, started over. My page with comments are loading my “Talk comment section” fine. I make a cp of plugins.defaults.json, name it plugins.json and add the lines for talk-plugin-like & love. cat plugins.json to confirm changes, docker restart container, cat plugins.json to double confirm the for lines for the like and love plugins are there. check.

Reload my comments page, but still just the “respect” button, no like or love.

Gotta be something basic, I’m overlooking…


I just renamed plugins.default.json to .bkup and restarted the container, no joy. Still just the “respect” button. So there must be another file to edit to turn on these plugins.


If you want to turn on other plugins, you need to use our *-onbuild images. See:

It’s important that you re-build the image after you’ve changed things, as we need to rebuild the static assets (rebundle the javascript) using webpack, that the onbuild image is designed to do. I’d recommend going the From source route if you’re new to Docker, as it’s quite a handful to learn all the ins and outs of Docker. Just remember to run yarn build after you make changes to the plugins.json file!


I was just reading that article this AM. Will try and let you know.Thanks!



I using the “Install from Source” instrucs. I removed all my previous images (talk, redis, mongo). I’ve got redis and mongo dbs running, but not the talk image. Here my question. Should I create a file called …env? I don’t see one already created.

I’m stuck here:

We should then specify the configuration variables that can be used to run the application locally in a file named .env. This will be read by the application when running in development mode:



The .env file is not created by default because it is environment specific.

You should create a file in the root of the Talk directory called .env with the contents you indicated.

The same goes if you want to change the plugins, you should create the plugins.json yourself by copying the plugins.default.json file.


Yoooooo!!! That worked like a charm. You’re the Best! Thanks for the help!