Looking for Help with Talk Plugin Google Auth


#1

Hey All! I could use some help setting up the Talk-Plugin-Google-Auth.

Here’s what I’ve done so far:

  1. created Google+ API and generated a Client ID and Client Secret.
  2. Added “talk-plugin-google-auth” to plugins.json

Where I’m lost:
Where do I put the client ID and secret?
Any other files I need to edit before I rebuild the docker image?

I’m on Ubuntu, Docker, yarn…

Thanks in advance.


#2

Make sure you’re using the onbuild option for Docker: https://docs.coralproject.net/talk/installation-from-docker#onbuild

This allows you to use custom plugins - more info in above link.

Check out how to use environment variables with Docker Compose here: https://docs.docker.com/compose/environment-variables/#pass-environment-variables-to-containers

The client ID and secret for Google, Facebook, and any other env variables for other plugins would be done this way.


#3

KG, Thanks for the reply. How would I use that onbuild image, if I was using the “install from Source” method?


#4

If you’re installing Talk from source, you could just run redis and mongo as you normally would, then you can clone the Talk repo, and add a plugins.json and .env file.

Are you running Talk locally like this? Or this for a production blog/site?


#5

I’m running Talk on one of our older pages on our website, on our server.
I understand how to add the more plugins to the plugins.json. Where (what file) to I put the client ID and client Secret? That’s what’s confusing? Does the client ID, client Secret go in the .env?


#6

Yep! All your secrets will go in the .env file. If you’re not using Docker you can simply create a file called .env in the root directory of Talk :slight_smile:


#7

Also were you not able to get it working with Docker in the end? How to turn on the other plugins?


#8

The other plugins (like, love reaction buttons) worked fine, thank you for the help. Now, I’m tasked with getting email verification, google+ auth, and Toxicity (Perspective) plugins working.

I’m running mongo and redis in containers and used yarn build for Talk (install from Source).


#10

Solved this myself. Needed to correct “callback” url, firewall rules, etc.


#11

Oh perfect, great news!