Notification reply/hourly/daily not showing the toggle button


#1

I enabled the following plugins:

  • talk-plugin-notifications
  • talk-plugin-notifications-category-reply
  • talk-plugin-notifications-digest-daily
  • talk-plugin-notifications-digest-hourly

But I can’t see the toggle buttons inside my profile. On reply, it throws an error stating notification is not enabled which is understood. How to fix it? Please note that We are using our own auth system.


#2

Hey @sajalsinha! Make sure you’re rebuilding after enabling plugins, also make sure you have them enabled for both server and client.

If you have more issues, please log a Github issue here: https://github.com/coralproject/talk/issues

Thanks!
Kim


#3

Hi @kgardnr,
Yes. The above stated plugins are enabled for both client and server. Did rebuild. After failing to figure out why, I decided to ask in the community. Ok, I’ll create an issue in GitHub.
Thanks,
Sajal


#4

Oh! I see what you’re missing, you need the actual category plugins too. So add:

talk-plugin-category-featured
talk-plugin-category-reply
talk-plugin-category-staff