mozilla

Unable To Display Comment Box With Wordpress Post


#1

Finally took some time to play around with it on my laptop and ran into problem with wordpress plugin

I activated Talk inside Wordpress but nothing is showing under the post

Here’s what it looks like

My setup:
standard wordpress install --> http://www.example.com
docker talk install --> http://www.example.com:3000

Is there anything else I need to configure?


#2

Hi Pedro

Did you whitelist your domains in the Configure tab in the admin section? It’s under Technical settings. If you don’t enter all of the domains and subdomains of your site, Talk won’t launch.

Let me know if that doesn’t do the trick!

Andrew


#3

Hi Andrew

Under tech settings I have following:
www.example.com
www.example.com:3000

Saved settings and refresh post. Still nothing showing.

I also verified that the wordpress plugin is activated


#4

Can you share your site so we can take a look? Or you can email it to support@coralproject.net


#5

I’ve set up the site on my laptop to give it a try. Can you let me know how I can share it for review?


#6

Hmm okay. Let me think.

Can you see the Talk admin locally? Via: http://www.example.com:3000/admin


#7

Yes. I’m able to view that page as well as change the permitted domains and other settings.

On the wordpress post I am seeing this error message at the bottom of the browser:

Loading failed for the < script > with source “http://www.example.com/static/embed.js”.


#8

Are there any console errors?


#9

Only error is the one posted earlier. Showing this:

Loading failed for the < script > with source “http://www.example.com/static/embed.js”.

If I use wordpress do I still need to do the following:

Copy and paste code below into your CMS to embed your comment box in your articles


#10

Do you have settings setup here: https://mysite.com/wp-admin/options-general.php?page=talk-settings

With mysite = your domain


#11

Also note the other directions in the README: https://github.com/coralproject/talk-wp-plugin


#12

I can access Talk at http://www.example.com:3000/admin

Should I use the same URL for both like this?

Talk Server Base URL: http://www.example.com:3000/
Talk Static Asset URL: http://www.example.com:3000/


#13

Base URL - perfect

Static asset URL should be the root for where your blog articles are (probably minus port?)


#14

Finally got it working thanks to @kgardnr for the assistance

This doesn’t work:
Talk Server Base URL: http://www.example.com:3000
Talk Static Asset URL: http://www.example.com

This works:
Talk Server Base URL: http://www.example.com:3000
Talk Static Asset URL: http://www.example.com:3000


#15

Ohhhh wonderful news!! Thanks for bearing with me :slight_smile: Excited to hear your feedback!


#16

Is it possible to improve helpful tips for beginners

Maybe reference the URL from the admin embed code?

Also both the links (talk root & talk static) shown in blue go to error page


#17

Yep! I fixed those links just now actually :slight_smile:

And we will improve the info there too